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RG-1000e Upgrade to Firmware R3.0 Guide

This document describes how to upgrade the RG-1000e firmware to version R3.0. All manufactured RG-1000e
units with firmware R1.* or R2.* can be upgraded to R3.0.

To upgrade RG-1000e to firmware R3.0, you need the following equipment and software:
° RG-1000e CPS R3.0.
° RG-1000e firmware files:

- RG1000e-3v00.bin

- RG1000e-3v00.boot

- RG1000e-3v00.rom

. USB cable A-miniB.

° External power supply 12-14 VDC, 0.5 A.

o Desktop computer or laptop with OS Windows 7/8/8.1/10.

Attention!

° You must use only CPS R3.0 for upgrading the RG-1000e to firmware R3.0. Using other CPS versions,

such as R1.* or R2.*, leads to corruption of the firmware data. In this case, the RG-1000e unit must be
delivered to the service center for recovery.

° To perform the firmware upgrade, you must disconnect the RG-1000e from all donor radios, disconnect
the Ethernet cable, and connect the unit to an external power supply via the power socket (for details, see
section 4.3 in RG-1000e User Guide).

The process of the RG-1000e upgrade to firmware version R3.0 includes the following steps:

Copy the CPS RG-1000e R3.0 files to the computer.

Run CPS RG-1000e R3.0 and switch it to the service mode.

Connect the RG-1000e unit to the computer and power up the device.
Establish a connection between CPS RG-1000e and the RG-1000e.

Create a new (default) RG-1000e configuration.

Specify the RG-1000e IP settings for initial remote IP access to the RG-1000e.
Flash the DSP firmware.

Write the new configuration.
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Flash the Boot firmware.
Flash the MCU firmware.
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1. Copy the CPS R3.0 files to a folder on your computer and run the program.

When you connect the RG-1000e gateway to the computer for the first time, the operating system detects
connection of a new device and requires the driver installation. For information on the USB driver installation
procedure, see Appendix 1.
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Run CPS R3.0. After the program starts, the home screen appears.
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2. Switch the program to the service mode. Click Options -> Service on the menu bar, and then, in the
Service code box, type Recovery_Service. Click Enter.

CPS RG-1000e - oW
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Ensure the service code validity. In the left part of the window, in the menu tree, expand the Tasks node. It must
have an only child node - Flash DSP firmware.

3. Connect the RG-1000e unit to the computer and power up the device.
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4, Establish a USB connection between CPS RG-1000e and the RG-1000e unit. Click Tasks -> Connect to
gateway on the menu bar, and then, in the window that appears, in the Connection type box, select the USB
option, and then click Enter.
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11:08:42- > Gakeway Ria-1000& connected to the USE bus

If the RG-1000e connection to the USB bus is established successfully, the corresponding message appears in
the Reports panel.
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5. Create a new (default) RG-1000e configuration. Click File -> Create on the menu bar, and then, in the

window that appears, click Yes.

CPS RG-1000e -
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Reports
11:03:42- > Gateway RG-1000e connected to the USE bus
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11:13:14-> RG-1000& gateway configuration is downloaded
11:13:14- = RG-1000e gateway new configuration is created
11:08:42- > Gateway RG-1000e connected to the 1156 bus

If the configuration is created and downloaded successfully, the corresponding messages appear in the Reports
panel. In the menu tree in the left part of the window, more nodes appear, and more child nodes appear under
the Tasks node (Read, Write, Flash DSP firmware, Flash Boot firmware, Flash MCU firmware, Reset).
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6. Specify the RG-1000e IP settings that may be considered as default for initial remote IP access to the RG-
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! Common Y

Mode [ protocol of connection TCP, RTP =

Gateway IP settings
IP address 192,168, 100,001

Subriet mask. 255,255.000,000

Gateway 192.165.200.001

Paort #CMP protocol, 102565535 30010 E

Parts RTP streams, 1025, 65535
Audio ARS TMS Location Telemetry
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Remote Gateway IP settings
IF address 10,254,254, 100
Port XCMP protocol, 1025, 65535 30010 3

Reset | | Save | | Close

Reparks

11:13:14-> R3-1000e gakteway configuration is downloaded
11:13:14-% Ri53-1000e gateway new configuration is created
11:08:42-» Gateway RG-1000e connected to the USE bus

Open the IP channel 8 window and configure the channel settings.

In the Mode/Protocol of connection boxes, select the Server and the TCP, RTP options.

In the IP address box, specify 192.168.100.001
In the Subnet mask box, specify 255.255.0.0

In the Gateway box, specify 192.168.200.001 (provided that the RG-1000e and the computer where CPS RG-
1000e is installed reside on the same LAN segment).
In the Port XCMP protocol box, specify 30010 (note that it is recommended that you use port 30010 for IP
remote access only and not use it for regular SmartPTT operations).
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Open the Mux window. Under the IP Channels heading, select the 8 check box in the Radio 2 row (regardless

of how the Radio 2 port is actually used).
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11:13:14-> Ra-1000e gateway configuration is downloaded
11:13:14-> RiG-1000e gateway new configuration is created
11:08:42- > Gateway RG-1000e connected ko the USE bus




RG-1000e Upgrade to Firmware R3.0 Guide December 2018
7. Flash the DSP firmware. In the menu tree in the left part of the window, double-click the Flash DSP

firmware node. In the window that appears, select the RG-1000e-3v00.rom DSP firmware file, and then click
Open.
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The flashing process starts automatically.

Do not interrupt the process! Do not power off the RG-1000e! Do not disconnect the RG-1000e from the
computer!
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11:44:54-= Writing process is running

11:13:14-> RG-1000e gateway configuration is downloaded
11:13:14-> RG-1000e gateway new configuration is created
11:08:42-> Gateway RG-1000e connected to the USE bus

When the firmware flashing process is complete, the firmware validating process starts automatically.
Do not power off the RG-1000e! Do not disconnect the RG-1000e from the computer!
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If the flashing process is completed successfully, in the Reports panel, the “Data validation is completed.

Wrong 0 bytes” message appears.
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Reports

11:44;57- = Data validation is completed, Wrong O bytes
11:44;56- = Data validation is running

11:44;56- = Writing process is completed, transferred 36604 bytes,
11:44:54- = \Writing process is running

11:13:14-= RE-1000e gateway configuration is downloaded
11:13:14-= RE-1000e gateway new configuration is created
11:08:42- > Gateway RG-1000e connected to the USE bus

If the message in the Reports panel indicates an error, power off the RG-1000e, disconnect it from the computer,
close CPS RG-1000e, and start the firmware flashing from step 1. If after the fifth attempt the flashing process
still fails, contact SmartPTT Tech Support about the problem.

8. Write the new configuration to the RG-1000e. In the menu tree in the left part of the window, click Tasks
- > Write to start writing the new RG-1000e configuration.

Do not disconnect the RG-1000e from the computer! Do not power off the RG-1000e!

If the new RG-1000e configuration is written successfully, in the Reports panel, the “Data validation is
performed. Wrong 0 bytes” message appears.

Reports

11:55:25- = Data validation is completed. Wrong 0 bytes
11:55:25-= Data validation is running

11:55:25-= Writing process is completed, transferred 2936 bytes,
11:55:24- > Writing process is running

11:44:57-= Data validation is completed. Wrong 0 bytes
11:44:56-= Data validation is running

11:44:56-= Writing process is completed, transferred 36604 bvtes,
11:44:54- = Writing process is running

11:13:14-= R3-1000e gateway configuration is downloaded
11:13:14-> Riz-1000e gateway new configuration is created
11:08:42- = Gateway RG-1000& connected ko the USE bus
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9. Flash the Boot firmware. In the menu tree in the left part of the window, double-click the Flash Boot

firmware node. In the window that appears, select the RG-1000e-3v00.boot Boot firmware file, and then click
Open.
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The flashing process starts automatically.

Do not interrupt the process! Do not power off the RG-1000e! Do not disconnect the RG-1000e from the
computer!
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Reports

12:01:15-> MCU writing process is running

11:55:25-» Daka validation is completed. Wrong O bytes
11:55:25- Daka validation is running

11:55:25- Writing process is completed, transferred 2986 bytes,
11:55:24-= Writing process is running

11:44:57- Daka validation is completed, Wrong 0 bytes
11:44:56- > Daka validation is running

11:44:56- = Writing process is completed, transferred 36604 bytes,
11:44:54- > Writing process is running

11:13:14-> RG-1000e gateway configuration is downloaded
11:13:14-> Ri3-1000e gateway new configuration is created
11:08:42-» Gakeway RG-1000e connected to the USE bus

When the firmware flashing process is complete, the firmware validating process starts automatically.
Do not power off the RG-1000e! Do not disconnect the RG-1000e from the computer!
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If the flashing process is completed successfully, in the Reports panel, the “Validation errors are not detected.

Data validation is completed” message appears.
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Reports

12101:23-> Data validation is completed,

12:01:23-> Validation errors are not detected,

12:01:23- The number of repeated queries =0

12:01:19-= Data validation is running

12:01:19-= Writing process is completed, transferred 2548 bytes,
12:01:15- MCU writing process is running

11:55:25-= Data validation is completed. Wrong 0 bytes
11:55:75- = Data validation is running

11:55:25-= Writing process is completed, transferred 2936 bytes.
11:55:24-= Writing process is running

11:44:57-= Data validation is completed, Wrong 0 bytes
11:44:56-= Data validation is running

11:44:56-= Writing process is completed, transferred 36604 bytes.
11:44:54- = Writing process is running

11:13:14-> Ri3-1000e gateway configuration is downloaded
11:13:14-= RG-1000e gateway new configuration is created
11:08:42-> Gateway RG-1000s connected to the USE bus

If the message in the Reports panel indicates an error, power off the RG-1000e, disconnect it from the computer,
close CPS RG-1000e, and start the firmware flashing from step 1. If after the fifth attempt the flashing process
still fails, contact SmartPTT Tech Support about the problem.
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10. Flash the MCU firmware. In the menu tree in the left part of the window, double-click the Flash MCU

firmware node. In the window that appears, select the RG-1000e-3v00.bin MCU firmware file, and then click
Open.
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11:44:56-> Writing process 15 completed, transferred
11:44:54-2 Writing process is running

11:13:14-> RG-1000e gateway configuration is downloaded
11:13:14-=» RG-1000e gateway new configuration is created
11:08:42- > Gateway RiE-1000e connected to the USE bus

B&U4 bytes,




RG-1000e Upgrade to Firmware R3.0 Guide December 2018
The flashing process starts automatically.

Do not interrupt the process! Do not power off the RG-1000e! Do not disconnect the RG-1000e from the
computer!

5]
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Reparts

12:09:44-= MCU writing process is running

12:01:23-= Data validation is completed.

12:01:23-= Yalidation errors are not detected.,

12:01:23-> The number of repeated gueries =0

12:01:19-> Data validation is running

12:01:19-= \Writing process is completed, transferred 2548 bytes.
12:01:15-= MU writing process is running

11:55:25- = Data validation is completed. Wrong 0 bytes
11:55:#5-= Data validation is running

11:55:25-= \Writing process is completed, transferred 2986 bytes.

When the firmware flashing process is complete, the firmware validating process starts automatically.
Do not power off the RG-1000e! Do not disconnect the RG-1000e from the computer!
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If the flashing process is completed successfully, in the Reports panel, the “Validation errors are not detected.

Data validation is completed” message appears.
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Reports

12:17:54- = Data validation is completed.

12:17:54- = Validation errors are not detected.

12:17:54- > The number of repeated queries =0

12:13:52- = Data validation is running

12:13:52- = Writing process is completed, transferred 165616 bytes,
12:09:44-= MCU writing process is running

12:01:23- = Data validation is completed.

12:01:23- = Yalidation errors are not detected.

12:01:23-> The number of repeated queries =0

12:01:19-> Daka validation is running

12:01:19-= 'Writing process is completed, transferred 2548 bytes,
12:01:15-= MCU writing process is running

11:55:25- > Data walidation is completed, Wrong 0 bytes
11:55:25-> Data validation is running

11:55:25- = Writing process is completed, transferred 2986 bytes,
11:55:24-= Writing process is running

11:44:57- = Daka validation is completad. Wrong O bytes
11:44:56-= Data validation is running

11:44:56- = Writing process is completed, transferred 36604 bytes,
11:44:54-= Writing process is running

11:13:14-> Ri3-1000e gateway configuration is downloaded
11:13:14-= Ri3-1000e gateway new configuration is created
11:08:42- > Gateway RE5-1000e connected to the USE bus

If the message in the Reports panel indicates an error, power off the RG-1000e, disconnect it from the computer,
close CPS RG-1000e, and start the firmware flashing from step 1. If after the fifth attempt the flashing process
still fails, contact SmartPTT Tech Support about the problem.

11. Power-off the RG-1000e. Do not disconnect the RG-1000e from the computer USB port.

12. Switch the program to the customer mode by clicking Options -> Custom on the menu bar.

13. Power up the RG-1000e. Wait for 15-20 seconds until the RG-1000e starts after flashing with the new

firmware.
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If the RG-1000e has started successfully, its front LEDs start blinking in the following way:

1) AIlILEDs are down.

2) AllI LEDs are blinking fast.

3) The Radio 1 / Radio 2 LEDs are permanently on, the Link LED is blinking slowly (with approximate
frequency of 1 Hz).

14, Ensure the RG-1000e connection to the USB bus is re-established successfully. The corresponding
message must appear in the Reports panel.
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12:38:57- > Gateway RiG-1000& connected to the JSE bus ™
12:35:47- > Gateway RG-1000e disconnected from the IJSE bus

12:38:47-> Commands transmission error: 2 error=-116

12138 46- = Gakeway RiG-1000& connected ko the USE bus

12:24:23- > Gateway RG-1000e disconnected from the IISE bus

12:24:19-> Ri3-1000& gateway configuration is downloaded

12:24:19-> RG-1000e gateway configuration is downloaded

12:17:54-> Data walidation is completed.

12:17:54-= Yalidation errors are not detected,

If the connection has not been re-established, you can do it manually. Click Tasks -> Connect to gateway on the

menu bar. In the window that appears, in the Connection type to the gateway box, select the USB option, and
then click Enter.

15. Read the RG-1000e. Click Tasks -> Read on the menu bar. Alternatively, you can expand the Tasks node
in the tree menu in the left part of the window, and then select Read.
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After that, in the tree menu in the left part of the window, click the Info node. In the window that appears,

ensure the MCU FW and the DSP FW version is 3.0.0.

@ RG-1000¢ - Info ==l =
< elcomplis  satevey ro-tooce

Model: RG-10002 MAC: 00:50:C2:B6:02:06

SM, ooi1 Date: 10.04.2017

DSP FW: 2.0.0 MICL FW: 3.0.0

OSSP DIE: 0x29120F42008E40D23 MCU UID: Ox002D003C35355115
OSSP CHIF: 0x2551

16. Disconnect the RG-1000e from the USB bus.

17. Connect the Ethernet ports of the RG-1000e and the computer on which CPS RG-1000e is installed to
the same LAN segment (for example, to the same L2 switch).

Establish an Ethernet connection between CPS RG-1000e and the RG-1000e. Click Tasks -> Connect to gateway
on the menu bar.

a CPS RG-1000e
File  Tasks Panels Options  Window  Help
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Connection type to the gateway: METW CRE
Metwork intetface address: 192,168.200.1

The network address of the gateway: 192,168,100.1

TCP gakeway pork, 1025, 65535 30010 |5

In the window that appears, in the Connection type box, select the Network option.
In the Network interface address, specify the IP address of the computer.

In the Network address of the gateway box, specify the RG-1000e IP address.

In the TCP gateway port, specify the gateway TCP (XCMP) port.
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If the connection is established successfully, in the Reports panel, the corresponding message appears (for

example, “TCP->The gateway is connected 192.168.200.1[51296] <=> 192.168.100.1[30010]").

File  Tasks Panels Options  Window  Help
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13:33:05- > TCP->The gateway is connected 192, 168.2DEI_. 1[512_96] <=3 192,168,100,1[30010] ~

18. Read the RG-1000e. Click Tasks -> Read on the menu bar. Alternatively, you can expand the Tasks node
in the tree menu in the left part of the window, and then select Read.

After that, in the tree menu in the left part of the window, click the Info node. In the window that appears,
ensure the MCU FW and the DSP FW version is 3.0.0.
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Feparts

13:38:57-> Riz-1000e gateway configuration is downloaded

13:38:57-» Reading process is completed, received 3240 bytes,

13:38:57-> Reading process is running

13:3305- > TCP-=The gateway is connected 192,168,200, 1[51296] <=>=> 192,168,100,1[30010]
13:33:02-» TCP->Conneckion to gateway 192,168,100,1[(30010]

12:52:33-» Gateway Ri5-1000e disconnecked From the USE bus

1Z2:48:22-» R3-1000e gateway configuration is downloaded

12:43:20- » Reading process is completed, received 3240 bytes,

12:46:20- » Reading process is running




